nginx中的PATH_INFO为什么会影响$_SERVIER['PHP_SELF']

发现问题:
使用ThinkPHP3.2.2在nginx部署网站,设置URL_MODEL=2,使用U方法在本地生成的链接形如:/public/index
但是在部署在nginx上却出现了问题 其中的URL生成了./public/index

通过追寻ThinkPHP源码在ThinkPHP.php文件中发现了如下代码:

    if(IS_CGI) {
            //CGI/FASTCGI模式下
            $_temp  = explode('.php',$_SERVER['PHP_SELF']);
            define('_PHP_FILE_',   rtrim(str_replace($_SERVER['HTTP_HOST'],'',$_temp[0].'.php'),'/'));
        }else {
            define('_PHP_FILE_',    rtrim($_SERVER['SCRIPT_NAME'],'/'));
        }

这是问题的根源
访问:http:www.xxx.com/public/index
在apache下$_SERVER['PHP_SELF']显示./index.php/public/index
而在nginx中显示空白

访问:http:www.xxx.com/index.php/public/index
在apache下$_SERVER['PHP_SELF']显示./index.php/public/index
而在nginx中显示/public/index

最后发现是在nginx开启PATH_INFO时出现了奇异。
我的nginx 中PATH_INFO段的配置是:

fastcgi_split_path_info ^(.+?\.php)(/.*)$;
set $path_info $fastcgi_path_info;
fastcgi_param PATH_INFO       $path_info;  #只要设置了这行PHP_SELF返回的就出问题
try_files $fastcgi_script_name =404;

回复内容:

发现问题:
使用ThinkPHP3.2.2在nginx部署网站,设置URL_MODEL=2,使用U方法在本地生成的链接形如:/public/index
但是在部署在nginx上却出现了问题 其中的URL生成了./public/index

通过追寻ThinkPHP源码在ThinkPHP.php文件中发现了如下代码:

    if(IS_CGI) {
            //CGI/FASTCGI模式下
            $_temp  = explode('.php',$_SERVER['PHP_SELF']);
            define('_PHP_FILE_',   rtrim(str_replace($_SERVER['HTTP_HOST'],'',$_temp[0].'.php'),'/'));
        }else {
            define('_PHP_FILE_',    rtrim($_SERVER['SCRIPT_NAME'],'/'));
        }

这是问题的根源
访问:http:www.xxx.com/public/index
在apache下$_SERVER['PHP_SELF']显示./index.php/public/index
而在nginx中显示空白

访问:http:www.xxx.com/index.php/public/index
在apache下$_SERVER['PHP_SELF']显示./index.php/public/index
而在nginx中显示/public/index

最后发现是在nginx开启PATH_INFO时出现了奇异。
我的nginx 中PATH_INFO段的配置是:

fastcgi_split_path_info ^(.+?\.php)(/.*)$;
set $path_info $fastcgi_path_info;
fastcgi_param PATH_INFO       $path_info;  #只要设置了这行PHP_SELF返回的就出问题
try_files $fastcgi_script_name =404;

这个$_SERVER与服务器的配置有很大关系

try_files $fastcgi_script_name =404;这个去掉就可以了,$_SERVER['PHP_SELF']这个就会有的

不需要去掉 try_files $fastcgi_script_name =404; 这个配置是解决php.ini配置项cgi.fix_pathinfo=1时的安全漏洞的。这个问题是楼主的服务器php.ini配置为cgi.fix_pathinfo=0造成的错误